ROBOTC.net forums
http://robotc.net/forums/

Bluetooth API status
http://robotc.net/forums/viewtopic.php?f=1&t=218
Page 1 of 1

Author:  dtrotzjr [ Wed Jul 04, 2007 5:01 pm ]
Post subject:  Bluetooth API status

I was looking to use the BT API built into RobotC but the sample sorta works, except I cannot change anything without strange behavior. I wanted to simply set a default pin and it will not work.
I am running 1.07
What is the status of the BT implementation?
Thanks,

-- David Trotz

Author:  dtrotzjr [ Mon Jul 16, 2007 2:07 am ]
Post subject: 

bump

Author:  JamesD [ Mon Jul 16, 2007 7:48 am ]
Post subject: 

What do you mean by use the BT API? What are you trying to do with BT that exhibits strange behaviour?

Author:  dtrotzjr [ Tue Jul 17, 2007 12:45 am ]
Post subject: 

I want to be able to: Connect to my PC using BT from a RobotC app. Then with the brick as a master and my pc as a slave use std NXT BT Messaging to send and receive messages. All I see that exists is one way from the brick to the slave (in my case PC) by using send file. I would prefer the standard BT messaging. I currently am using nXc to accomplish my BT goals, but if RobotC had BT Messaging I could come back to it.
-- David

Author:  JamesD [ Tue Jul 17, 2007 8:48 am ]
Post subject: 

Hi David,

Unfortunately, I can't help you as I'm not an expert in BT or C based programming but I hope someone can as we need all the community based expertise we can muster. As will be demonstrated in a minute when I post a question for you in your very cool sensor drivers post. :)

Page 1 of 1 All times are UTC - 5 hours [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/