View unanswered posts | View active topics It is currently Wed Aug 05, 2020 1:27 am






Reply to topic  [ 1 post ] 
Vista / Bluetooth / RobotC - a junk drawer success! 
Author Message
Rookie

Joined: Thu Dec 03, 2009 12:33 pm
Posts: 2
Post Vista / Bluetooth / RobotC - a junk drawer success!
Hello!

Like many others I've seen posting here, and at some of the other NXT sites, I'd been having a hard time getting my Vista equipped laptop to connect to the NXT with RobotC. When I got the laptop, I specifically bought a BT dongle listed on the Vista hardware compatibility list, which was a Belkin F8T012. Thing has worked like a champ for everything except the RobotC/NXT connection.

Now mind you, the same dongle had no problem whatsoever making the RobotC/NXT connection on my Windows XP Pro desktop.

So I tried all the things I found in the different posts to resolve my Vista issues - Reset the brick, reset the BT, make sure the com port is below 9, update the drivers, and so on. I could pair the laptop and the NXT with either one initiating the pairing, but not through RobotC. I even went out and bought a D-link DBT-120 that was supposedly NXT and Vista compatible. Although my BT stack is only a couple of months old, and listed the DBT-120 as being compatible (Broadcom on both the XP and Vista machines), Vista could not find the necessary drivers. And the CD that came with the new dongle wanted to install a Toshiba stack.

Arg!

So a few days later, I was working on another project on my desktop computer, and found a significant incompatibility problem between the BASIC programming language I was using, and the F8T012 dongle. Of course the same combination worked fine on the Vista laptop. While I thought it might be a problem with the desktop, trying the same combination on yet another XP machine also crashed!

Bluetooth doth vex me!

Time to start using X-bee radios instead of BT. And as I sat there, i realized that in the junk drawer I had my foot propped up on, I had an old, moldy, vintage belkin F8T001 dongle. What the heck. plugged it into the XP machine, drivers install, BASIC program now works fine.

Hmmm......

Even though there's no indication the dongle is compatible with Vista, plugged the same crusty old dongle into the Vista laptop. "Found New hardware", Installing drivers", "Driver installation failed". But wait - when Vista popped up the "Installing drivers' message, I had accidentally clicked it. It opened, and displayed what it was doing during the process. You know what - all the advanced features like wireless sound failed to install. On the other hand, Serial com installed!

So here's the punchline - fired up RobotC, and I can now connect the vista laptop to the NXT. Even though the assigned com port is 13! Go figure.

I guess the moral of the story is, don't give up. If you have an old dongle laying around, give it a try. It just might do the trick.

Paul G.


Fri Feb 26, 2010 3:13 am
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 1 post ] 

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  



Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.