View unanswered posts | View active topics It is currently Wed Sep 23, 2020 2:46 pm






Reply to topic  [ 11 posts ] 
Starting to have compiling problems 
Author Message
Novice

Joined: Fri Jan 18, 2008 11:07 pm
Posts: 51
Location: Ohio
Post Starting to have compiling problems
I have RobotC 2.01, so that compiler problem with 2.00 was fixed for a while...

I am now having all kinds of compiler problems. The .c file is huge with several subroutines and tasks (6 total tasks). It uses 4 of Xanders sensor includes and loads about 8 sound files. It's a pretty sizable download. The download will get bigger if my plan works too.

Now I am having problems when I do simple things. I throw in a PlayTone command to hear when the program gets to a point. Then later I go in to remove that, but it continues to play the tone??? I have erased it, commented it out and everything I can think of. But sometimes when I go in and change the frequency and duration the tone responds.

I am chasing my tail and it's driving me nuts. Any thoughts? :x


Sat Feb 20, 2010 5:10 pm
Profile
Site Admin
Site Admin
User avatar

Joined: Wed Mar 05, 2008 8:14 am
Posts: 3654
Location: Rotterdam, The Netherlands
Post Re: Starting to have compiling problems
Shep, in the preferences, see if turning off incremental downloads makes a diff:

Image

- Xander

_________________
| Professional Conduit of Reasonableness
| (Title bestowed upon on the 8th day of November, 2013)
| My Blog: I'd Rather Be Building Robots
| ROBOTC 3rd Party Driver Suite: [Project Page]


Sat Feb 20, 2010 5:26 pm
Profile WWW
Novice

Joined: Fri Jan 18, 2008 11:07 pm
Posts: 51
Location: Ohio
Post Re: Starting to have compiling problems
X,
I have thrown that switch. Let me try it for a while and I will get back to on whether it works or not.
Shep


Sat Feb 20, 2010 6:17 pm
Profile
Novice

Joined: Fri Jan 18, 2008 11:07 pm
Posts: 51
Location: Ohio
Post Re: Starting to have compiling problems
I am closing in on my problem. I have gotten into the habit of not saving the program before recompiling. It has worked up to now.

I just modified the program and downloaded it without saving and it didn't work. I went back and manually saved the file, then compiled and downloaded it and it worked.

It seems that there is a bug in the "Auto Save before recompile" checkbox in preferences/Editor tab. Possibly caused by large downloads.


Sun Feb 21, 2010 9:23 pm
Profile
Novice

Joined: Fri Jan 18, 2008 11:07 pm
Posts: 51
Location: Ohio
Post Re: Starting to have compiling problems
OK, I am almost certain I have found the bug. My "Save" doesn't work. In cases of hitting the save button, or auto-save when compiling and downloading

Case 1.
I modified the program, tried to download without saving, mods didn't work (autosave didn't work)
Then I saved the program with the button, compiled, mods sometimes work.
Then I Saved and closed the file, reopened it, compiled and it worked.

Case 2.
Changed a file by adding a simple "int" declaration.
Closed the file and hit OK to "Save changes to xxxx.c"
Reopened the file and the changes I made were not there.

In short, the compiled program on the NXT does not match the code that I have written. It uses previous downloads. AHHHHH!

I often have several relatively large files open, and each download sound files and have a few #includes. I feel as tho I have hit a compiler size limit. Is this possible???


Sun Feb 21, 2010 10:28 pm
Profile
Site Admin
Site Admin
User avatar

Joined: Wed Mar 05, 2008 8:14 am
Posts: 3654
Location: Rotterdam, The Netherlands
Post Re: Starting to have compiling problems
Shep,

Enable the compiler statistics and make a screenshot of them to show me. You can enable it in the preferences:
Image

It should look like this:
Image

- Xander

_________________
| Professional Conduit of Reasonableness
| (Title bestowed upon on the 8th day of November, 2013)
| My Blog: I'd Rather Be Building Robots
| ROBOTC 3rd Party Driver Suite: [Project Page]


Mon Feb 22, 2010 2:35 am
Profile WWW
Novice

Joined: Fri Jan 18, 2008 11:07 pm
Posts: 51
Location: Ohio
Post Re: Starting to have compiling problems
Xander,
Check your inbox.
Chris


Mon Feb 22, 2010 5:49 pm
Profile
Novice

Joined: Thu Jan 28, 2010 6:13 pm
Posts: 51
Post Re: Starting to have compiling problems
I'm having a similar problem even if in different condition (see my post). The compiled program seems not to initialize the motors and sensors. I've tried almost all the combinations of "Save", "Compile", "Compile adn Download" with random results: sometimes it works adn sometimes not. Up to now i haven't found a logic in it :(


Mon Feb 22, 2010 7:04 pm
Profile
Site Admin
Site Admin
User avatar

Joined: Wed Mar 05, 2008 8:14 am
Posts: 3654
Location: Rotterdam, The Netherlands
Post Re: Starting to have compiling problems
Peeps,

I've forwarded the problem to the devs and made them aware of this thread. I'll try and speak with one of them today.

- Xander

_________________
| Professional Conduit of Reasonableness
| (Title bestowed upon on the 8th day of November, 2013)
| My Blog: I'd Rather Be Building Robots
| ROBOTC 3rd Party Driver Suite: [Project Page]


Tue Feb 23, 2010 2:54 am
Profile WWW
Novice

Joined: Fri Jan 18, 2008 11:07 pm
Posts: 51
Location: Ohio
Post Re: Starting to have compiling problems
Any word?

I am finding that if I save and close the file, it usually comes back up correctly. Then I compile and download and I am having some success. I am also trying to have fewer files open too. If I am not working in that program, I shut it down. That's kind of a pain when programming 4 NXTs, but at least it seems to keep problems down.

Shep


Fri Feb 26, 2010 10:05 pm
Profile
Site Admin
Site Admin
User avatar

Joined: Wed Mar 05, 2008 8:14 am
Posts: 3654
Location: Rotterdam, The Netherlands
Post Re: Starting to have compiling problems
Chris,

No, nothing from them, just that the ticket's in the system now. I will ask what the story is.

- Xander

_________________
| Professional Conduit of Reasonableness
| (Title bestowed upon on the 8th day of November, 2013)
| My Blog: I'd Rather Be Building Robots
| ROBOTC 3rd Party Driver Suite: [Project Page]


Sat Feb 27, 2010 3:50 am
Profile WWW
Display posts from previous:  Sort by  
Reply to topic   [ 11 posts ] 

Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  



Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.