ROBOTC.net forums
http://robotc.net/forums/

Sound files won't play
http://robotc.net/forums/viewtopic.php?f=1&t=5269
Page 1 of 1

Author:  Shep [ Sun Dec 16, 2012 8:59 pm ]
Post subject:  Sound files won't play

For some reason, my sound files won't play
PlaySoundFile("! StartUp.rso");

The sound file is resident on the NXT. Tones and PlaySound works fine, just the .rso files.

I'm stumped. :?

Author:  JohnWatson [ Mon Dec 17, 2012 4:30 pm ]
Post subject:  Re: Sound files won't play

I was able to test this in ROBOTC 3.54 and it works fine; one thing to remember is to put a wait command (wait1MSec(1000), for example) after the PlaySoundFile command to ensure that the program has enough time to play the sound file properly. Also, make sure you have the most up-to-date version of ROBOTC installed (currently 3.54) to ensure that any past bugs are fixed.

Author:  Shep [ Mon Dec 17, 2012 10:53 pm ]
Post subject:  Re: Sound files won't play

It must have been a bug in 3.5x. I tried the code of four NXTs and none of them worked before upgrading. Then I upgraded to the current version and the same code worked on all four.

Thanks. :bigthumb:

Page 1 of 1 All times are UTC - 5 hours [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/