View unanswered posts | View active topics It is currently Thu Oct 23, 2014 10:26 am






Reply to topic  [ 1 post ] 
My Joystick debugger says "joystick not equipped" 
Author Message
Rookie

Joined: Sun Oct 19, 2014 5:21 pm
Posts: 1
Post My Joystick debugger says "joystick not equipped"
My joystick debugger says "joystick not equipped" but when I go to "Joystick Control-Basic" or "Joystick Control-Competition" it works fine. What is the problem? this is a copy of my code

#pragma config(Hubs, S1, HTMotor, HTServo, none, none)
#pragma config(Sensor, S1, , sensorI2CMuxController)
#pragma config(Motor, mtr_S1_C1_1, motorD, tmotorTetrix, openLoop)
#pragma config(Motor, mtr_S1_C1_2, motorE, tmotorTetrix, openLoop, reversed)
#pragma DebuggerWindows("JoystickSimple")'


#include "JoystickDriver.c"

task main()
{
while(1 == 1) // Infinite loop:
{
getJoystickSettings(joystick);

motor[motorD] = joystick.joy1_y1; // Motor D is assigned a power level equal to the right analog stick's Y-axis reading.
motor[motorE] = joystick.joy1_y1;
}
}


Sun Oct 19, 2014 8:05 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 1 post ] 

Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  



Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.