ROBOTC.net forums
http://robotc.net/forums/

Can't find RobotC 3.61.1 patch
http://robotc.net/forums/viewtopic.php?f=1&t=5972
Page 1 of 1

Author:  Ernest3.14 [ Fri Jun 14, 2013 7:22 pm ]
Post subject:  Can't find RobotC 3.61.1 patch

I seem to have encountered the error described here: http://www.robotc.net/blog/2013/06/11/r ... -1-update/
But when I click on the "NXT downloads page" link provided in the text, I get redirected here:
http://www.robotc.net/download/nxt/index.php
I might just be missing something, but I can't seem to find the actual link to the patch :( I've tried re-installing both the NXT drivers (32- and 64-bit, although I have a 64-bit machine) and the RobotC program. Nothing has worked so far. Suggestions? Even better, a link to the patch? :)

Author:  mightor [ Sat Jun 15, 2013 2:06 am ]
Post subject:  Re: Can't find RobotC 3.61.1 patch

It's probably not a patch but a simple installer that you run again.

= Xander

Author:  Ernest3.14 [ Sun Jun 16, 2013 12:49 am ]
Post subject:  Re: Can't find RobotC 3.61.1 patch

Ok, I get it now. I was getting an issue with the Fantom.dll file, but a re-install fixed that. I still get the "encountered an improper argument" error. The "Help -> About ROBOTC" menu tells me that I am running ROBOTC 3.61 (not 3.61.1?) with firmware 9.68; build date is June 10th, 2013. That seems to be the issue, as 3.61.1 was released June 11th...
I got the installer here (the big "Download version 3.61.1" button): http://www.robotc.net/download/nxt/index.php
I'll try again tomorrow and see what happens :/

Author:  mightor [ Sun Jun 16, 2013 2:33 am ]
Post subject:  Re: Can't find RobotC 3.61.1 patch

I installed 3.61.1 yesterday and this is what my about box says:
Attachment:
2013-06-16_08-30-23.png
2013-06-16_08-30-23.png [ 99.5 KiB | Viewed 7414 times ]


I am positive it's 3.61.1, though :) The date you see in the about box is the build date of the binaries. That does not mean that it was packaged up that day. They build it and then test it, that could take a day.

= Xander

Author:  Ernest3.14 [ Sun Jun 16, 2013 1:09 pm ]
Post subject:  Re: Can't find RobotC 3.61.1 patch

Well... Ok. My about box looks just like that. But it still doesn't work :(
After a clean install, newly downloaded firmware and a test program, I still get the "improper argument" error once I open "Joystick Control - FTC". The drop-down menus for choosing joysticks are blank, despite having a Logitech gamepad connected (the FTC ones). (They worked last season.) Clicking on "Audible Feedback" gives a steady signal, but once I attempt to click "Dual Joysticks" RobotC crashes. What is going on? :?

Attachments:
Crash.png
Crash.png [ 201.89 KiB | Viewed 7398 times ]
Joystick Control - FTC.png
Joystick Control - FTC.png [ 162.92 KiB | Viewed 7398 times ]
Improper Argument.png
Improper Argument.png [ 21.24 KiB | Viewed 7398 times ]

Author:  Ernest3.14 [ Sun Jun 16, 2013 1:12 pm ]
Post subject:  Re: Can't find RobotC 3.61.1 patch

I haven't installed anything using the discs which come with the gamepad, since I didn't need to last year. Might that be the issue?

Author:  mightor [ Sun Jun 16, 2013 4:20 pm ]
Post subject:  Re: Can't find RobotC 3.61.1 patch

Do a complete uninstall, make sure you remove ALL the left-overs still in the program folder manually and then reinstall.

= Xander

Author:  Ernest3.14 [ Mon Jun 17, 2013 1:55 pm ]
Post subject:  Re: Can't find RobotC 3.61.1 patch

At first I found some stuff in my "Program Files (x86)" folder, but deleting those didn't fix the problem. So I'm just going to go back to 3.60 and wait for the 4.0 betas :)

Page 1 of 1 All times are UTC - 5 hours [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/