View unanswered posts | View active topics It is currently Sat Sep 26, 2020 8:29 am






Reply to topic  [ 1 post ] 
I2C / External Controller (TETRIX, MATRIX) Support in 4.10? 
Author Message
Rookie

Joined: Sun Aug 24, 2014 7:27 pm
Posts: 1
Post I2C / External Controller (TETRIX, MATRIX) Support in 4.10?
I see there is a marketing release about 4.10 that says "Initial Support for I2C devices with EV3 platform". Is this in reference to the Tetrix controllers? I can't get them to work. (I'm actually using HiTechnic controllers if that is relevent). Please let me know if these are currently being supported, and if they're not, if there is any rough timeline of when they are expected to be supported. (I understand no timeline may exist).

The following code:

#pragma config(Hubs, S1, HTMotor, HTServo, none, none)
#pragma config(Motor, mtr_S1_C1_1, motorE, tmotorNormal, openLoop, reversed)
#pragma config(Motor, mtr_S1_C1_2, motorF, tmotorNormal, openLoop)

Produces the following error message:

**Error**:Invalid '#pragma config(Motor, ...)' syntax: Bad motor device index 'mtr_S1_C1_1'
**Error**:Invalid '#pragma config(Motor, ...)' syntax: Bad motor device index 'mtr_S1_C1_2'


Sun Aug 24, 2014 7:31 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 1 post ] 

Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  



Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.