View unanswered posts | View active topics It is currently Fri Oct 31, 2014 3:03 am






Reply to topic  [ 5 posts ] 
Cortex acting wierd 
Author Message
Rookie

Joined: Thu Jul 08, 2010 3:50 pm
Posts: 18
Post Cortex acting wierd
i've recently purchased a brand new cortex and downloaded robotc 2.25. i then downloaded the master firmware and the robotc firmware. but every time i turn on the cortex all the motors turn on, even having the usb cable connected doesnt do anything all the motors still turn on. what is going on?


Sat Oct 02, 2010 9:48 am
Profile
Site Admin
Site Admin

Joined: Tue May 15, 2007 9:02 am
Posts: 405
Post Re: Cortex acting wierd
Have you tried downloading one of the sample programs, to see if that changes the robot behavior? If you go to "File" > "Open Sample Program" > "Basic Movement" there are a few programs that will turn on the motors for just a few seconds, as opposed to forever.

_________________
Jesse Flot
CMU Robotics Academy
ROBOTC Support


Mon Oct 04, 2010 11:18 am
Profile
Rookie

Joined: Thu Jul 08, 2010 3:50 pm
Posts: 18
Post Re: Cortex acting wierd
Yes I have tried to download a program and there is no change


Mon Oct 04, 2010 11:45 am
Profile
Site Admin
Site Admin

Joined: Tue May 15, 2007 9:02 am
Posts: 405
Post Re: Cortex acting wierd
Can you describe your setup, and the steps you've taken so far? That will help me pinpoint what the problem might be.

Were the Master CPU Firmware and ROBOTC Firmware both successfully downloaded, or did they give you error messages?

Are you programming over the USB A-to-A cable, or wirelessly using VEXnet?

Are the sample program downloads successful? What sample programs have you tried?

Is your "VEX Cortex Download Method" set to "Download using USB Only" or "Download using VEXnet or USB"?

_________________
Jesse Flot
CMU Robotics Academy
ROBOTC Support


Thu Oct 07, 2010 12:27 pm
Profile
Rookie

Joined: Thu Jul 08, 2010 3:50 pm
Posts: 18
Post Re: Cortex acting wierd
To answer your questions:
yes, the firmware, both, were downloaded succesfully.

i am downloading using an A-A usb cable.

yes, the sample programs are downloaded successfully, iv'e tried both the servo sweep to try and run my servos, and two of the motor programs to run the linear actuators.

i am using the usb only method for download.

i think part of the problem is that immediatly when i turn on the cortex it attempts to bring my servos to the middle of their stroke, i don't know if there is a way to not have it do this. also, i'm not sure that the cortex has the ability to output to all 8 devices at one time. plus, the linear actuators are supposed to run on 12V but the cortex and motor controllers can only handle 7.2V. i think i may need to go with a different microcontroller and motor controllers.


Thu Oct 07, 2010 2:21 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 5 posts ] 

Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  



Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.