View unanswered posts | View active topics It is currently Sat Jul 26, 2014 7:08 am






Reply to topic  [ 5 posts ] 
"ABORTED. Failed to communicate with robot" in ROBOTC 2.32 
Author Message
Novice
User avatar

Joined: Sat Jul 10, 2010 3:06 pm
Posts: 86
Location: Roanoke, VA
Post "ABORTED. Failed to communicate with robot" in ROBOTC 2.32
I get an error whenever I attempt to download code via VEXnet to my robot. It seems to successfully download code, but before launching the debugger it displays the error: "ABORTED. Failed to communicate with robot."
However, everything is wired correctly - the serial cable is plugged in to the VEXnet remote. The VEXnet keys are not the problem; I've tried using the USB A-A cable to tether the remote and Cortex, but with the same result.

I was not experiencing this problem before switching to ROBOTC 2.32. I will be competing at the VRC Championship next week, so I would like to resolve this issue as soon as possible.

Any suggestions?

Thanks,
Andrew

_________________
Check out my website! www.RoboDesigners.com

VRC Team 2190

Twitter: @RoboDesigners


Fri Apr 08, 2011 9:21 pm
Profile WWW
Rookie

Joined: Mon Jan 03, 2011 5:40 pm
Posts: 12
Post Re: "ABORTED. Failed to communicate with robot" in ROBOTC 2.32
We had this same problem, which we fixed by changing out the batteries in the joystick. Even though the joystick light was green, I guess they were low. :?


Fri Apr 08, 2011 9:31 pm
Profile
Site Admin
Site Admin

Joined: Tue May 15, 2007 9:02 am
Posts: 403
Post Re: "ABORTED. Failed to communicate with robot" in ROBOTC 2.32
Hi RoboDesigners,

Did you also update the firmware on your VEXnet Joysticks?

Can you verify that your batteries are fully charged?

Please keep us posted on your issue so that we can look into it further.

Thanks,
- Jesse

_________________
Jesse Flot
CMU Robotics Academy
ROBOTC Support


Mon Apr 11, 2011 11:23 am
Profile
Novice
User avatar

Joined: Sat Jul 10, 2010 3:06 pm
Posts: 86
Location: Roanoke, VA
Post Re: "ABORTED. Failed to communicate with robot" in ROBOTC 2.32
jbflot wrote:
Did you also update the firmware on your VEXnet Joysticks?

Yes

jbflot wrote:
Can you verify that your batteries are fully charged?

The battery light on the remote was green, so I guess they were...

I can't test it right now (robot and remote are packed for World), but I'll keep you posted when I do test it...

Andrew

_________________
Check out my website! www.RoboDesigners.com

VRC Team 2190

Twitter: @RoboDesigners


Mon Apr 11, 2011 10:51 pm
Profile WWW
Novice
User avatar

Joined: Sat Jul 10, 2010 3:06 pm
Posts: 86
Location: Roanoke, VA
Post Re: "ABORTED. Failed to communicate with robot" in ROBOTC 2.32
Sorry for the late response, but...

The problem went away after I changed the batteries in the joystick. (even though the light was "green" on the joystick)

Andrew

_________________
Check out my website! www.RoboDesigners.com

VRC Team 2190

Twitter: @RoboDesigners


Tue Apr 19, 2011 12:55 pm
Profile WWW
Display posts from previous:  Sort by  
Reply to topic   [ 5 posts ] 

Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  



Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.