VEXnet won't connect after download
Page 1 of 1

Author:  SeanTPR [ Tue Oct 25, 2011 5:59 am ]
Post subject:  VEXnet won't connect after download

Got a problem getting the cortex and joystick controller to connect after downloading a program.

Using the cortex 2.0, RobotC version 3.03, all the latest firmware (VEX_cortex_0903.hex, WIFI_RC_2p0_V3_16.BIN, WIFI_OI_2p0_V3.BIN), using the straight USB-to-USB connection (we're competing in BEST, and our hub doesn't supply the programing USB-to-serial cable, though we'll probably be buying our own soon), on a Windows XP Service Pack 3 machine with the 32-bit driver. Batteries charged, all the standard basic troubleshooting stuff is good. Download method USB only; however, on the RobotC Preferences screen, platform tab, the Communications port drop-down menu lists only automatic selection and several COMM ports (there is no USB option).

After downloading the master CPU and RobotC firmware, the VEXnet link will connect--green lights on the ROBOT, VEXnet, and joystick. But after powering down and removing the VEXnet keys and connecting the USB cable again, and downloading ANY program (not just our custom competition program but the sample programs as well), powering down and plugging in the VEXnet key and turning the cortex back on again, the cortex and joystick won't connect over VEXnet.

Repeating the process of reinstalling the firmware (master CPU and RobotC) will restore the ability to connect via VEXnet (once the cortex and joystick controller are re-sync'd via the USB cable), but again, downloading any program results in the VEXnet being unable to connect. With a program downloaded, even in tethered mode (with the VEXnet keys removed and the cortex and joystick controller connected via the USB cable) the two won't link.

Another issue that we've noted (but doesn't affect us yet, since we can't get VEXnet to connect with a program downloaded but will once that's fixed) is that the cortex and joystick controller cannot be calibrated. By using the VEXnet link prior to downloading any program (that is, while the VEXnet link is still operational), and going through the calibration procedure (holding down the 6U button on the joystick controller while simultaneously pressing the recessed CONFIG buttong on the cortex), the cortex/joystick controller won't enter the calibration mode, which is supposed to be indicated by the joystick light flashing red and green. Ours just sits there staying green, no red at all, despite keeping the 6U and CONFIG buttons depressed for more than 30 seconds.

So . . . what are we doing wrong here?

Author:  jbflot [ Tue Oct 25, 2011 4:21 pm ]
Post subject:  Re: VEXnet won't connect after download

It sounds like your Robot > VEX Cortex Download Method should be set to "Download using VEXnet or USB". Choosing "Download using USB Only" disables VEXnet, which would explain why it won't connect.

Author:  alicexxx [ Thu Nov 19, 2015 1:06 am ]
Post subject:  Re: VEXnet won't connect after download

Just asking how you worked this problem out eventually because our group is facing the exact same problem.
We have tried to set the download method to "Download using VEXnet or USB", but that did not make a difference.


Page 1 of 1 All times are UTC - 5 hours [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group