View unanswered posts | View active topics It is currently Mon Jul 28, 2014 6:21 am






Reply to topic  [ 4 posts ] 
My W7 pc bluescreened while using RobotC with VEX 
Author Message
Rookie

Joined: Sun Nov 20, 2011 12:06 pm
Posts: 14
Post My W7 pc bluescreened while using RobotC with VEX
My windows 7 pc (Dell) bluescreened while i was monitoring vex sensors with RobotC debugger. This is the second time in last 3 days. What could be the problem?

Here is the problem window contents after reboot:
Problem signature:
Problem Event Name: BlueScreen
OS Version: 6.1.7601.2.1.0.768.3
Locale ID: 1033

Additional information about the problem:
BCCode: d1
BCP1: 00000004
BCP2: 00000002
BCP3: 00000000
BCP4: 8AE5B018
OS Version: 6_1_7601
Service Pack: 1_0
Product: 768_1

Files that help describe the problem:
C:\Windows\Minidump\112011-15022-01.dmp
C:\Users\hpm\AppData\Local\Temp\WER-37596-0.sysdata.xml


Sun Nov 20, 2011 2:07 pm
Profile
Site Admin
Site Admin

Joined: Tue May 15, 2007 9:02 am
Posts: 403
Post Re: My W7 pc bluescreened while using RobotC with VEX
The most likely cause is the driver for the programming cable. I would recommend uninstalling the driver for the cable, downloading the latest version, and reinstalling it.

You can find the download here: http://www.vexforum.com/wiki/index.php/ ... _Downloads

_________________
Jesse Flot
CMU Robotics Academy
ROBOTC Support


Mon Nov 21, 2011 12:39 pm
Profile
Guru
User avatar

Joined: Sun Nov 15, 2009 5:46 am
Posts: 1347
Post Re: My W7 pc bluescreened while using RobotC with VEX
hmoor14 wrote:
Problem signature:
Problem Event Name: BlueScreen
OS Version: 6.1.7601.2.1.0.768.3
Locale ID: 1033

Additional information about the problem:
BCCode: d1
BCP1: 00000004
BCP2: 00000002
BCP3: 00000000
BCP4: 8AE5B018
OS Version: 6_1_7601
Service Pack: 1_0
Product: 768_1

Files that help describe the problem:
C:\Windows\Minidump\112011-15022-01.dmp
C:\Users\hpm\AppData\Local\Temp\WER-37596-0.sysdata.xml

BCCode: 0xd1 means DRIVER_IRQ_NOT_LESS_OR_EQUAL
BCP1: 00000004 (Address of memory being referenced)
BCP2: 00000002 (IRQL at time of reference - IRQL_DISPATCH)
BCP3: 00000000 (It's a read reference)
BCP4: 8AE5B018 (Address that referenced memory)

In summary, it means the driver was executing at IRQL_DISPATCH (i.e. it is at a critical time that no paging operation is allowed) but the driver code is making a read reference to a memory location (0x00000004) that was not present in memory.

First, the information should have the driver name that caused the fault but you did not include this information. Secondly, 0x00000004 does not look like a valid memory address. It looks like the driver is referencing memory by a NULL pointer (4 probably means the second DWORD of a structure pointed to by a NULL pointer).

Regardless, the problem lies with the driver that faulted.

The minidump file (C:\Windows\Minidump\112011-15022-01.dmp) will contain more useful information.

BTW, you can find detail description of this bugcheck here.
http://msdn.microsoft.com/en-us/library ... 44(v=VS.85).aspx


Mon Nov 21, 2011 2:18 pm
Profile
Rookie

Joined: Sun Nov 20, 2011 12:06 pm
Posts: 14
Post Re: My W7 pc bluescreened while using RobotC with VEX
I uninstalled the VEX programming 32-bit driver and the Prolific PL-2303 USB-to-Serial win7 driver, downloaded latest version, reinstalled both (VEX 1st, Prolific 2nd).
I tested on same robot - no problems so far!
Thanks!


Mon Nov 21, 2011 4:12 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 4 posts ] 

Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron



Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.