View unanswered posts | View active topics It is currently Sun Sep 20, 2020 11:40 pm

Reply to topic  [ 3 posts ] 
Prolific USB-Serial Driver not working 
Author Message

Joined: Thu Oct 25, 2012 7:16 pm
Posts: 4
Post Prolific USB-Serial Driver not working
Hi Guys. I downloaded the driver last year, and everything ended up working fine. This year, I'm running RobotC 3.5 in my classroom, and no students can get communication using the USB-Serial cable. Joysticks and Cortex units pair just fine (well, mostly), but we can't use the VEXnet connection. I used my administrator access to look at Device Manager (we're on Windows 7). The Prolific USB-Serial driver is listed but with a yellow "!". And hence, no communication between the computer and the joystick by way of serial cable.

I tried re-downloading the driver, I tried installing the driver using my "administrator priviledges."
I tried updating RobotC to version 3.51.
I tried plugging the cable into the back of the computer.

I'm running out of ideas. Any thoughts would be appreciated!

Thu Oct 25, 2012 7:27 pm
Site Admin
Site Admin

Joined: Thu May 24, 2012 12:15 pm
Posts: 722
Post Re: Prolific USB-Serial Driver not working
If you have a yellow exclamation mark by the driver name in Windows Device Manager, the issue more than likely lies with the driver itself. I would suggest uninstalling the driver completely, rebooting the computer, and then redownloading and reinstalling the driver ( You will have to ensure the that the driver is installed on an admin account and there are no programs on the computer that could be restricting the driver install. If this is on a school computer, I would suggest getting the IT department in play as well to ensure there aren't any hidden restrictions that might be causing the driver issue.

Check out our Blog! And our Facebook page!
Need help? Take a look at our updated help documentation and the ROBOTC Forums.

Fri Oct 26, 2012 9:49 am

Joined: Thu Oct 25, 2012 7:16 pm
Posts: 4
Post Re: Prolific USB-Serial Driver not working
Oddly, I got things working by switching the USB-Serial Driver to an old version from 2008.
The driver is version Nothing else would work.

Does this seem normal? What happens if I ever (accidently) delete my 2008 version of the driver? Is there a fix for this?

Wed Oct 31, 2012 7:46 pm
Display posts from previous:  Sort by  
Reply to topic   [ 3 posts ] 

Who is online

Users browsing this forum: No registered users and 2 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.