Issue with downloading firmware to Vexnet Joystick
Page 1 of 1

Author:  mattcdempsey [ Sat Oct 27, 2012 10:17 am ]
Post subject:  Issue with downloading firmware to Vexnet Joystick

Hi All,

I am currently trying to download code onto my Vex Cortex Controller but I am running into a problem.
Every time I try to download the code an error message pops up that reads:
"Vex Cortex Controller Master Firmware Version (0.0) is out of date (3.23) Upgrade Required."

To fix this I went to : Robot > Download Firmware > Automatically Update Vexnet Joystick
This action attempts to install the new 3.23 standard file, but states that the firmware is already updated.
I try this again by manually updating the joystick firmware and receive a message that it has been successfully installed.

However, when I go back to compile and download the Dual Joystick control code, I again receive the error message that the firmware is out of date.

I have tried re-configuring the joystick, using the firmware upgrade utility and trying this whole thing out with another joystick. I am not having these problems with the cortex. Any help or suggestions you can offer would be great.

Author:  JohnWatson [ Mon Oct 29, 2012 11:24 am ]
Post subject:  Re: Issue with downloading firmware to Vexnet Joystick

I believe the problem you are seeing is that the Cortex firmware is out of date, but the VEXNet Joystick's firmware is being updated to compensate. Both the Cortex and the Joystick have separate firmwares; updating one won't automatically update the other.

To solve this, first make sure you have the most recent version of ROBOTC installed (currently 3.51) and freshly charged batteries installed. Then, plug the Cortex into the computer directly using the USB A-to-A portion of the programming cable and select 'Automatically update VEX Cortex' from the firmware update menu. Just to be safe, manually connect the Joystick controller using the USB A-to-A cable and select 'Automatically update VEXNet Joystick' to update the Joystick's firmware as well. Once both are updated, you should be able to reconnect as normal and download/run programs on the Cortex via the VEXNet Joystick controller.

If it is still giving you problems, please provide us with the Software Inspection results (found in the Robot menu under 'Advanced Tools'), the exact hookup you are using (which cables you are using and what is plugged into on another), and any other relevant information you can.

Author:  mddale [ Fri Dec 06, 2013 6:51 pm ]
Post subject:  Re: Issue with downloading firmware to Vexnet Joystick

I am having a similar problem: The CONTROLLER firmware updated fine and we were able to load autonomous program and run it. The robot moved fine. However, several times, using both automatic and manual mode, we have uploaded the 3.23 JoyStick firmware (got all of the "successful" messages"), yet when subsequently trying to load a program to the JoyStick, we get the error:
Vex Cortex controller master firmware version (0.00) is out of date (3.23). Update Required.

Batteries are good. I have tried removing/re-installing the batteries in hope that might "reboot" it. The USB A-A cable is connected. We are running WINDOWS 7. ROBOTC V:3.62, F/W 9.68.

Author:  rhondacrawford [ Thu Jan 16, 2014 5:35 pm ]
Post subject:  Re: Issue with downloading firmware to Vexnet Joystick

I am having this issue and followed these steps. Help!!! We have competition this Saturday. I went to Software Inspection and this is the results:

Communications Link: COM Port 'COM5' to VEXNET Joystick

Standard Firmware File Names:
VEXNET Joystick: .\Firmware\JOY_V3_23.BIN
VEX Cortex Master CPU Firmware: .\Firmware\CORTEX_V3_23.BIN
VEX Cortex CPU Firmware: .\Firmware\VEX_Cortex_0968.hex

VEXnet Joystick Integrity:
Firmware Version: 3.23 Up to Date
Battery Voltage: 4.3V Poor (<6.1V)
Calibrated: No
Joystick State: Powering Up

Cortex Master CPU Integrity: Value Status
Data not available

Cortex User CPU Integrity: Value Status
Data not available.

Author:  JohnWatson [ Fri Jan 17, 2014 10:29 am ]
Post subject:  Re: Issue with downloading firmware to Vexnet Joystick

How are you downloading the firmware to the Cortex? You will want to make sure that the Cortex is physically plugged into the computer using the USB A-to-A cable instead of doing the firmware update over VEXNet.

Please walk me through the process you are taking, step by step, as this will help us determine where any potential issues may be.

Author:  mddale [ Fri Jan 17, 2014 4:32 pm ]
Post subject:  Re: Issue with downloading firmware to Vexnet Joystick


Here are our steps in trying to load to the JOYSTICK software:
using a ROBOTC graphical interface and this Application path:

Robot / Download Firmware / Manually Update firmware / VEXnetJoystick Firmware / STANDARD FILE (JOY_V3_23.BIN)

The Joystick and computer PC are connected via the M/M USB-A cable and
We get these messages upon selection of the above function:

"Wait BOOT Loader
Erasing Vex Device
Writing Vex Device Firmware

Wait 10 seconds for Reboot
VEXnet Joystick firmware download succeeded

Firmware for VEXnet Joystick was downloaded successfully"

Then, with the Joystick still connected to the PC, we select this ROBOTC menu item:

File / Open Sample Program / VEX2 / Remote Control / Single Joystick Control.c

Then, we select the following function:

Robot / Compile & Download

and get this message:

"Activity Type 0%
Vex Cortex controller master firmware version (0.00) is out of date (3.23).
Robotc Message
Vexcortex controller master firmware version (0.00) is out of date (3.23)
Update Required."

So ..... perhaps the solution is to go directly to the VEXRobotic's web site to do the firmware update function and THEN to see if the ROBOTC functions work with the joystick.

Again, we were able to get the "brain" controller firmware to update AND we were able to load and execute a sample ROBOTC "autonomous" routine with the PC and "brain" connected via the USB A/A cable. The impasse is that we were not able to similarly load ROBOTC instructions to the Joystick so that we could thereafter operate the robot via the interactive joystick.

Author:  Savant [ Thu Feb 13, 2014 12:36 pm ]
Post subject:  Re: Issue with downloading firmware to Vexnet Joystick

Looking for help with a similar issue. I have the joystick connected to my PC using USB. It shows the device in the communication port (View>Select Communication Port). I keep Automatic Port selected. I have the joystick turned on and while it is in the middle of downloading the firmware, the link keeps cutting out. I've tried this with USB Only communication as well as USB or VexNet selected. I've also tried both automatic update as well as manual update. Same thing happens. Any idea why this is happening?

Author:  marlonbrando921 [ Tue Mar 29, 2016 2:41 am ]
Post subject:  Re: Issue with downloading firmware to Vexnet Joystick

The VEXnet Firmware Upgrade Utility overwrites the Master Code on the VEX ARM® Cortex®-based Microcontroller or a VEXnet Joystick to the latest version. Versions 3.0 or higher require a VEX Serial USB Driver installed on your PC (see the section Update PC Drivers above). This ZIP file includes the Upgrade Utility and instructions.

Page 1 of 1 All times are UTC - 5 hours [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group