View unanswered posts | View active topics It is currently Fri Sep 19, 2014 9:51 am






Reply to topic  [ 8 posts ] 
Program not downloading to PIC 
Author Message
Rookie

Joined: Tue Jan 08, 2013 6:08 pm
Posts: 4
Post Program not downloading to PIC
When I try to download a program to the PIC controller I get the error

Robot controller failed to respond.
Possibly not powered on or corrupted firmware.
Or low battery condition.
Or cable connections between controller and PC are wrong.
Or incorrect port is selected on PC.

I have followed the steps in the Getting Started guide exactly. I have searched for solutions to the error and I haven't found anything that worked. I saw that SmartBoard software can cause problems with Cortex, but I don't know about PIC. I'd like to know for sure because it would be a hassle to fix. Can anyone help me?


Mon Apr 08, 2013 4:38 pm
Profile
Rookie

Joined: Tue Jul 26, 2011 8:19 pm
Posts: 15
Post Re: Program not downloading to PIC
Just to check over the easy stuff:

    You have a fully charged battery plugged into the PIC
    You are using the orange cable provided for the PIC. It should be half phone cable/half USB cord and have a small box in the center
    You have installed the newest driver available and can confirm that the PIC is listed as COM# in the Device Manager
    You have downloaded all of the appropriate firmwares to the PIC (Master Firmware -> RobotC firmware)
    You have the platform configured as Innovation First (IFI)->VEX 0.5 PIC in the RobotC Robot->Platform Type Menu
    You have the Compiler Target set as Physical Robot

_________________
Member of the Sarah Heinz House VEX and FIRST teams.


Mon Apr 08, 2013 5:09 pm
Profile
Site Admin
Site Admin

Joined: Thu May 24, 2012 12:15 pm
Posts: 578
Post Re: Program not downloading to PIC
I agree with what Eddie has said; please double check all of those things to make sure they are not the culprit. Also, I would suggest using the 'IFI Loader 4 PIC' to attempt a download of the default PIC firmware. This will help narrow down if it is a ROBOTC specific issue or a different issue with the PIC/computer that is trying to download the firmware.

There are a couple more questions that can help us with the debugging as well:

Does this happen with only one PIC, or does it happen with multiple PICs?
Does this happen on one computer, or does it happen on multiple computers?
Does this happen with one specific USB cable, or does it happen with multiple cables?
Which version of ROBOTC is being used? (This can be checked by navigating to the 'Help -> About ROBOTC' menu option and noting the version number in the bottom left corner)

Thank you in advance for the information, the better the details you can give us the better we will be able to assist you.

_________________
Check out our Blog! And our Facebook page!
Need help? Take a look at our Wiki and our Forums.

I just met you,
And this is crazy,
But here's my code now,
So fix it, maybe?
~ Carly Rae Jepsen parody


Mon Apr 08, 2013 10:27 pm
Profile
Rookie

Joined: Tue Jan 08, 2013 6:08 pm
Posts: 4
Post Re: Program not downloading to PIC
Eddie, I have already triple checked those. I meant it when I said I followed the steps exactly.

John, We have tried it on two PIC's and we can only get access to one cable and one computer. We have tried 3.54 for Cortex and PIC and 2.02 for PIC.

Thank you both for your quick responses!


Tue Apr 09, 2013 4:58 pm
Profile
Rookie

Joined: Tue Jan 08, 2013 6:08 pm
Posts: 4
Post Re: Program not downloading to PIC
Bump


Tue Apr 16, 2013 4:50 pm
Profile
Rookie

Joined: Thu May 31, 2012 4:06 pm
Posts: 22
Location: Pittsburgh, Pa
Post Re: Program not downloading to PIC
Are you just starting out or did this randomly happen?

_________________
SHARP
Sarah Heinz Advanced Robotics Program

VEX 889A and FIRST 3260

Pittsburgh Champions Aerial Assist 2014
Pittsburgh and Buckeye Finalist Ultimate Ascent 2013
Toss Up Champions and Excellence-Pittsburgh
Toss Up Champions-Northwest Maryland VRC


Wed Apr 17, 2013 7:35 pm
Profile
Site Admin
Site Admin

Joined: Wed Jan 24, 2007 10:44 am
Posts: 439
Location: Pittsburgh, PA
Post Re: Program not downloading to PIC
Have you tried if 3.60 solves the issue?
http://www.robotc.net/download/cortex/

If not, it sounds like it might be a bad cable. Anyway, report back and let us know.

_________________
Vu Nguyen
Software Training Development Team | Webmaster
Need more support? Use the ROBOTC Ticketing system

Robotc.net| Robomatter Store | Robotics Academy | CS2N


Thu Apr 18, 2013 2:42 pm
Profile
Rookie

Joined: Thu Feb 14, 2013 2:41 pm
Posts: 2
Post Re: Program not downloading to PIC
There is a line of code that you need to put in the program. I used to use the PIC controller but it has been awhile and I don't remember the exact command. I will look around for my old programs and see if I can find an example.

Followup:
The line I was thinking of is

bIfiAutonomousMode= true;


Tue May 14, 2013 11:52 am
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 8 posts ] 

Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  



Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.