View unanswered posts | View active topics It is currently Mon Oct 19, 2020 10:39 pm

Reply to topic  [ 3 posts ] 
Cortex not getting communication 
Author Message

Joined: Mon May 06, 2013 2:18 pm
Posts: 1
Post Cortex not getting communication
I have had several cortexes recently lose communication permanently after I connected them through a USB cable to a vexnet controller.

The program downloads correctly.
I turn off cortex and controller and connect with USB.

Lights act as if communication is trying to be established, and end with vexnet light on cortex being red.

I turn off cortex and reconnect to computer.

When I go to update the firmware, it says "No communication link available to VEX device. Check that your device is connected to PC."

Lights on cortex are: ROBOT--slow blinking green
GAME-- fast blinking green

From that point forward I get nothing out of cortex. I have tried new batteries and orange cables but have so far only fixed it by swapping the cortex.

Any idea how to fix these cortex?

Mon May 06, 2013 2:40 pm
Site Admin
Site Admin

Joined: Thu May 24, 2012 12:15 pm
Posts: 722
Post Re: Cortex not getting communication
There are a couple of things I can suggest to help fix this problem. First, make sure you have administrator access before downloading the Cortex firmware for the first time on each computer.

Unplug the Cortex from the computer. With a battery plugged into the Cortex, plug the USB cable from the computer back into the Cortex, wait a few seconds for Windows to recognize the Cortex (you will see a popup window in the saying 'Installing Device Driver Software'), then turn on the Cortex.

Next, make sure that the correct drivers are installed for the Cortex. ROBOTC will download the drivers as it is being installed, but if the drivers are not installed correctly you can download from our website and install them manually. Depending on which cable is being used, you will either need the 'CORTEX & VEXnet Joystick Drivers'(USB A-to-A) or the 'Prolific USB-to-Serial Driver' (USB-to-Serial Cable). The Cortex will install a driver for each USB port that it is plugged into, so if you change ports please ensure that you install drivers for the new port. Both of the drivers need to be installed as administrator, and can be found on our download page under optional downloads:

The Cortex is not compatible with SMART Board software and will not work with SMART Board software installed. To resolve this issue, you must disable the SMART Virtual TabletPC driver in Windows Device Manager. Instructions on how to do so can be found here: ... ex_fix.pdf

Finally, make sure that the correct COM port is selected in ROBOTC. Navigate to the 'Select Communication Port' option from the 'View' menu in ROBOTC. From the Communications Port drop down list, you should see "Automatic Selection" and one of two additional options: If your VEX Cortex is in "bootload mode" or running an older (2.x) version of the Master CPU Firmware, it will appear as a "USB Wired Cable" option in the list. If your VEX Cortex is running a newer (3.x) version of the Master CPU Firmware, it will appear as a "Vex Robotics Comm Port" in the list. Make sure that "Automatic Selection" or one of the two legitimate options is selected.

If you ever plan on programming your robot wirelessly over VEXnet, choosing "Automatic Selection" is recommended. Press OK to save your choice. Important: If the "USB Wired Cable" or "Vex Robotics Comm Port" options do not appear in the drop down menu when a VEX Cortex is connected, this may indicate that Windows has not recognized the device or access to it is blocked. Ensure that the VEX Cortex Device Driver was successfully installed with Administrative Privileges, disconnect and reconnect your Cortex from the computer, and press "Refresh List" to force ROBOTC to repopulate the list.

Also, try different USB ports (the ones on the front of computers are sometimes unable to provide enough current to the Cortex for it to be recognized) and different cables, if possible. Note that the front USB ports on computers have been known to build up static which can cause intermittent disruptions to data transfers.

If you have followed all these steps and the problem still persists, please provide me with the driver name that is attached to the Cortex (found by navigating to the Device Manager in Windows Control panel; Start -> Control Panel -> Hardware and Sound -> Device Manager), the name of the port in ROBOTC's View -> Select Communication Port window, and any other information that appears (error messages, etc).

Check out our Blog! And our Facebook page!
Need help? Take a look at our updated help documentation and the ROBOTC Forums.

Tue May 14, 2013 4:40 pm

Joined: Fri Oct 04, 2013 9:51 am
Posts: 1
Post Re: Cortex not getting communication
We're having a similar problem. We have three cortexes that slow-blink (about a cycle per second) when given power from any source - battery, A-A USB, or both. According to the troubleshooting guide, we should re-download the firmware to the cortex. We try to do that, but the program freezes on the Download Progress 0% window.
We've tried different computers, different ports, different cortexes, different A-A cables, different batteries, all the same result.
Last week we successfully programmed two robots. Now there's nothing, and they won't even connect to the joysticks.

Fri Oct 04, 2013 10:39 am
Display posts from previous:  Sort by  
Reply to topic   [ 3 posts ] 

Who is online

Users browsing this forum: No registered users and 2 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.