ROBOTC.net forums
http://robotc.net/forums/

Why my motor does not stop turning on automatically?
http://robotc.net/forums/viewtopic.php?f=11&t=7763
Page 1 of 1

Author:  gb123 [ Tue Jan 21, 2014 11:57 am ]
Post subject:  Why my motor does not stop turning on automatically?

My first time to install the ROBOTC then i linked the A-A USB wire to my PC and to my Vex Cortex. Then according to the
guideline(from Help menu under Getting Started/Cortex/Getting Started with the Vex Cortex)
to test the Vex Cortex if it works is to insert a battery and two motors at port 2 and port 3. I already do this process.
When I turned on the switch at my Vex Cortex, the motors connected at port 2 and port 3 does not stop.
It started even if i did not click the start yet. It should not start unless if I click "Start" at compiler.
The program i used is a sample program named Moving Forward.C (under Basic Movement folder).

Why does my motors does not stop to turn on? It seems that my Vex Cortex does not read
the program that i compiled and download at ROBOTC compiler. Please help. I have no other solutions.
I cannot continue to the next step if this does not solve the issue. I am looking forward for your help.

Btw, I used this step here: http://www.robotc.net/wiki/Tutorials/Ge ... _using_USB

Thanks.

-GB-

Author:  JohnWatson [ Tue Jan 21, 2014 12:06 pm ]
Post subject:  Re: Why my motor does not stop turning on automatically?

Double check all of the wiring on your robot, and make sure the wires are plugged into the Cortex with the correct orientation (the white signal wire should be closest to the center of the Cortex and the black ground wire should be furthest away). Also, make sure your Motor Controller 29's (MC29) are connected to the motors correctly, with the red wire going to the red wire on the motor and the black going to the black.

If the motors are plugged in incorrectly, they will receive power and start running as soon as the Cortex is turned on.

Author:  gb123 [ Tue Jan 21, 2014 1:14 pm ]
Post subject:  Re: Why my motor does not stop turning on automatically?

Thank you very much JohnWatson! It works now!
I haven't connected the MC29 to the Motor 393. Sorry for my simple question. It is my first
time to install the Vex Cortex. Thanks again! :)

Page 1 of 1 All times are UTC - 5 hours [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/