Cannot connect to VEX device
Page 1 of 1

Author:  christopher1006 [ Thu Oct 23, 2014 8:07 pm ]
Post subject:  Cannot connect to VEX device

Hello, new member here and looking for help on fixing something that could cost us our competition that's in two days if not fixed. The programming was going well until we accidentally forgot to plug in the laptop while it was connected to the Cortex. After restarting the laptop and plugging it in, we were met with this:

'No communications link available to VEX device.
Check that your device is connected to the PC.'

We tried using a different laptop, reinstalling the drivers, disabling and reenabling the drivers and switching where the USB was plugged in to on the computer. Looking online, we haven't found downloads that appear to help. If anyone can point us in the right direction, I'd be very thankful.

Author:  mcmillanpanthers [ Mon Dec 01, 2014 4:02 pm ]
Post subject:  Re: Cannot connect to VEX device

We are students who are having the same problem. We have turned on the Cortex but it doesn't connect with ROBOTC.

Author:  JohnWatson [ Mon Dec 01, 2014 5:12 pm ]
Post subject:  Re: Cannot connect to VEX device

Have you followed the instructions outlined in the Getting Started with the VEX Cortex guide? This guide walks through the required process to get your Cortex up and running with ROBOTC; please look through it, closely follow all of the steps, and let us know what step the process fails on.

Please also let us know if the Cortex appears under the 'View -> Select Communications Port' menu, and what the Cortex appears as under the Windows Device Manager.

Author:  Up2NoGood [ Wed Dec 03, 2014 1:55 am ]
Post subject:  Re: Cannot connect to VEX device

I am new to Vex and RobotC and spent much of my day dealing with this exact issue today. What ultimately solved it for me was plugging in the cortex, ignoring the fact that it couldn't see the device there, and choosing the manual firmware update option. Somehow that was able to override whatever was telling it there was nothing plugged in, whereas the automatic update options were unable to find the device at all.

I have two cortexes and only one had this particular problem, but the auto firmware update wasn't fully effective on the other cortex either. It couldn't link to its joystick until I did the manual update option on that cortex as well, even after running the auto updater multiple times for both versions of the firmware. So give the manual update a try. Just be sure to run both versions.

Page 1 of 1 All times are UTC - 5 hours [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group