View unanswered posts | View active topics It is currently Fri Oct 30, 2020 7:05 am

Reply to topic  [ 4 posts ] 
Cannot connect to VEX device 
Author Message

Joined: Thu Oct 23, 2014 8:00 pm
Posts: 1
Post Cannot connect to VEX device
Hello, new member here and looking for help on fixing something that could cost us our competition that's in two days if not fixed. The programming was going well until we accidentally forgot to plug in the laptop while it was connected to the Cortex. After restarting the laptop and plugging it in, we were met with this:

'No communications link available to VEX device.
Check that your device is connected to the PC.'

We tried using a different laptop, reinstalling the drivers, disabling and reenabling the drivers and switching where the USB was plugged in to on the computer. Looking online, we haven't found downloads that appear to help. If anyone can point us in the right direction, I'd be very thankful.

Thu Oct 23, 2014 8:07 pm

Joined: Mon Dec 01, 2014 3:58 pm
Posts: 5
Post Re: Cannot connect to VEX device
We are students who are having the same problem. We have turned on the Cortex but it doesn't connect with ROBOTC.

Mon Dec 01, 2014 4:02 pm
Site Admin
Site Admin

Joined: Thu May 24, 2012 12:15 pm
Posts: 722
Post Re: Cannot connect to VEX device
Have you followed the instructions outlined in the Getting Started with the VEX Cortex guide? This guide walks through the required process to get your Cortex up and running with ROBOTC; please look through it, closely follow all of the steps, and let us know what step the process fails on.

Please also let us know if the Cortex appears under the 'View -> Select Communications Port' menu, and what the Cortex appears as under the Windows Device Manager.

Check out our Blog! And our Facebook page!
Need help? Take a look at our updated help documentation and the ROBOTC Forums.

Mon Dec 01, 2014 5:12 pm

Joined: Wed Dec 03, 2014 1:24 am
Posts: 1
Post Re: Cannot connect to VEX device
I am new to Vex and RobotC and spent much of my day dealing with this exact issue today. What ultimately solved it for me was plugging in the cortex, ignoring the fact that it couldn't see the device there, and choosing the manual firmware update option. Somehow that was able to override whatever was telling it there was nothing plugged in, whereas the automatic update options were unable to find the device at all.

I have two cortexes and only one had this particular problem, but the auto firmware update wasn't fully effective on the other cortex either. It couldn't link to its joystick until I did the manual update option on that cortex as well, even after running the auto updater multiple times for both versions of the firmware. So give the manual update a try. Just be sure to run both versions.

Wed Dec 03, 2014 1:55 am
Display posts from previous:  Sort by  
Reply to topic   [ 4 posts ] 

Who is online

Users browsing this forum: No registered users and 2 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.