View unanswered posts | View active topics It is currently Sat Dec 20, 2014 11:48 am






Reply to topic  [ 10 posts ] 
Third Party drivers on EV3 and 4.25 
Author Message
Rookie

Joined: Thu Nov 15, 2007 2:36 am
Posts: 15
Location: Australia
Post Third Party drivers on EV3 and 4.25
I got excited when I read the Botbench post on 4.25. Lots of goodness there.

I got VERY excited when I read that third party sensor drivers were supported. I quickly got out a soccer robot with a HT IR Seeker and a HT compass but I have been unable to get anything working. I have tried using the NXT sample code and some of our rather more verbose robot code we have that doesn't use the built in drivers (ie generic I2C sensor) but no luck - just a few sad beeps and unintelligible error messages.

Has anyone got this going yet?

_________________
neilg


Tue Aug 19, 2014 2:47 am
Profile
Moderator
Moderator
User avatar

Joined: Wed Mar 05, 2008 8:14 am
Posts: 3297
Location: Rotterdam, The Netherlands
Post Re: Third Party drivers on EV3 and 4.25
Hi Neil,

The third party drivers are still under development for the EV3. You can read the latest status here and the Changelog here.

= Xander

_________________
| Professional Conduit of Reasonableness
| (Title bestowed upon on the 8th day of November, 2013)
| My Blog: I'd Rather Be Building Robots
| ROBOTC 3rd Party Driver Suite: [Project Page]


Tue Aug 19, 2014 2:53 am
Profile WWW
Rookie

Joined: Thu Nov 15, 2007 2:36 am
Posts: 15
Location: Australia
Post Re: Third Party drivers on EV3 and 4.25
Ahhhh - thought that may have been the case. Would you like assistance in testing out the software?

I am a little concerned about the IRseeker - based on our experiences there seems to be something interesting going on there.

Regards,

Neil

_________________
neilg


Tue Aug 19, 2014 7:17 pm
Profile
Moderator
Moderator
User avatar

Joined: Wed Mar 05, 2008 8:14 am
Posts: 3297
Location: Rotterdam, The Netherlands
Post Re: Third Party drivers on EV3 and 4.25
Neil,

Could you be more specific about your experiences?

= Xander

_________________
| Professional Conduit of Reasonableness
| (Title bestowed upon on the 8th day of November, 2013)
| My Blog: I'd Rather Be Building Robots
| ROBOTC 3rd Party Driver Suite: [Project Page]


Wed Aug 20, 2014 12:52 am
Profile WWW
Rookie

Joined: Thu Nov 15, 2007 2:36 am
Posts: 15
Location: Australia
Post Re: Third Party drivers on EV3 and 4.25
The compass works fine on the EV3 with the HT custom blocks.

Not such a happy story with the IRSeeker.

The EV3 would lock up continually requiring a full reset to restore operations.

Eventually we improved the stability by putting the sensor scanning in a parallel process on a half second frequency and storing the value in a memory.

This value would then be picked up in the main control loop and used to implement proportional control. While considerably more stable we still had regular lockups - unacceptable in a Robocup Junior soccer competition.

Eventually we got around the problem by using the Tris10 IR sensors which were read as ultrasonic sensors. All was good.

In summary we concluded that there appeared to be a communication/timing issue with the IRSeeker. We have been waiting for the RobotC release hoping that would resolve the problem. To my knowledge there has been no reply from Hitechnics on the issue.

Our champion teams are using NXTs, RobotC and your driver suite.

Neil

_________________
neilg


Wed Aug 20, 2014 3:45 am
Profile
Rookie

Joined: Thu Nov 15, 2007 2:36 am
Posts: 15
Location: Australia
Post Re: Third Party drivers on EV3 and 4.25
We were using the Mindstorms EV3 software for this of course.

Very poor quality copy attached


Attachments:
Soccer.jpg
Soccer.jpg [ 135.96 KiB | Viewed 1074 times ]

_________________
neilg
Wed Aug 20, 2014 3:47 am
Profile
Moderator
Moderator
User avatar

Joined: Wed Mar 05, 2008 8:14 am
Posts: 3297
Location: Rotterdam, The Netherlands
Post Re: Third Party drivers on EV3 and 4.25
ROBOTC does not use the same I2C calls as the standard LEGO VM, so this may not be an issue.

= Xander

_________________
| Professional Conduit of Reasonableness
| (Title bestowed upon on the 8th day of November, 2013)
| My Blog: I'd Rather Be Building Robots
| ROBOTC 3rd Party Driver Suite: [Project Page]


Wed Aug 20, 2014 3:59 am
Profile WWW
Rookie

Joined: Tue Oct 22, 2013 11:00 am
Posts: 12
Location: Texas
Post Re: Third Party drivers on EV3 and 4.25 / 4.26
Downloaded drivers suite and tested them yesterday on the NXT with the HiTechnic Sensors as well as some from Dexter Industries

My results

EOPD
Magnetic
Compass

encounter compile issues

Instructions for setting up the suite followed
Every sample code loaded - ran into issues starting at the include line.

#include "drivers/hitechnic-magfield.h" needed to be changed to #include "drivers\hitechnic-magfield.h" so the error message not finding hitechnic-magfield.h would go away.

The sensors listed above all return the same error messages

**Error**:Undefined procedure 'SetSensorType'.
**Error**:Undefined procedure 'SetSensorType'.

Contacted HiTechnic- made changes to the settings in RobotC - checked all of the allow boxes in the sensors area

Message remained exactly the same.

Only 2 sensors so far appear to work as intended

Dexter Industries ThermalIR
Dexter Industries GPS - powers up but may not be allowing communication through as display never updates


Thu Oct 09, 2014 10:27 am
Profile
Moderator
Moderator
User avatar

Joined: Wed Mar 05, 2008 8:14 am
Posts: 3297
Location: Rotterdam, The Netherlands
Post Re: Third Party drivers on EV3 and 4.25
Hi there,

Please use the driver suite that is on Github. It has fixed many compiler issues. You can get it here: https://github.com/botbench/robotcdriversuite Just follow the instructions on that page :)

= Xander

_________________
| Professional Conduit of Reasonableness
| (Title bestowed upon on the 8th day of November, 2013)
| My Blog: I'd Rather Be Building Robots
| ROBOTC 3rd Party Driver Suite: [Project Page]


Mon Oct 20, 2014 3:45 am
Profile WWW
Rookie

Joined: Thu Nov 15, 2007 2:36 am
Posts: 15
Location: Australia
Post Re: Third Party drivers on EV3 and 4.25
Thanks Xander - will give it a go. Congratulations on the new job ! Should be a hoot.

_________________
neilg


Mon Oct 20, 2014 6:53 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 10 posts ] 

Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  



Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.