ROBOTC.net forums
http://robotc.net/forums/

problem with library "advanced sensor"
http://robotc.net/forums/viewtopic.php?f=41&t=11162
Page 1 of 1

Author:  CyD [ Tue May 12, 2015 6:44 am ]
Post subject:  problem with library "advanced sensor"

I am using a hitecnic compas in EV3 and when I am going to compilate the program this warns problems with the library

Code:
File "C:\Program Files (x86)\Robomatter Inc\ROBOTC Development Environment 4.X\Includes\AdvancedSensors.c" compiled on May 12 2015 12:31:04
*Warning*:Unreferenced function 'getRGB'
**Error**:Undefined procedure 'getI2CPolledData'.
*Warning*:Unreferenced function 'bColorMatched'
**Error**:Undefined procedure 'getI2CPolledData'.
*Warning*:Unreferenced function 'getAccel'
**Error**:Undefined procedure 'getI2CPolledData'.
**Error**:Undefined variable 'NO_ERR'. 'short' assumed.
**Error**:'case' statement expression must have constant value
**Error**:Undefined variable 'ERR_COMM_BUS_ERR'. 'short' assumed.
**Error**:'case' statement expression must have constant value
**Error**:Undefined variable 'STAT_COMM_PENDING'. 'short' assumed.
**Error**:'case' statement expression must have constant value
**Error**:'case' statement expression must have constant value
**Error**:'case' statement expression must have constant value
**Error**:'case' statement expression must have constant value
**Error**:'case' statement expression must have constant value
**Error**:'case' statement expression must have constant value
**Error**:'case' statement expression must have constant value
*Warning*:Unreferenced function 'findSensor'

Page 1 of 1 All times are UTC - 5 hours [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/