View unanswered posts | View active topics It is currently Fri Oct 31, 2014 11:52 am






Reply to topic  [ 4 posts ] 
Problems Running Automonous 
Author Message
Rookie

Joined: Sat Nov 22, 2008 7:14 pm
Posts: 12
Location: NJ
Post Problems Running Automonous
The new Automonous template won't run at all.

Anything I program won't run.

I debugged the program by stepping into it, and from what I have found the program goes to the beginning, goes to initialize robot, and then it skips the rest of the code and goes to the while loop.

Does anyone know how to fix this?

_________________
Ethan Spitz
Team 464 Programmer


Tue Feb 03, 2009 4:02 pm
Profile
Novice

Joined: Thu Oct 09, 2008 7:58 pm
Posts: 79
Post Re: Problems Running Automonous
Post your autonomous code.


Tue Feb 03, 2009 7:57 pm
Profile
Expert

Joined: Sun Aug 19, 2007 2:43 pm
Posts: 138
Location: New Jersey
Post Re: Problems Running Automonous
If your program happens to be still active when it "skips" your other code, it must be either it caught up ina loop, or somekind of switch that you use to stop that, etc. When you say "skip", does it mean it jumps to execute codes after that, or the execution simply was terminated, or just keeps running in some infinite loop...

Yeap... you need to be specific about the symptom... must give specific details... it can be whole gallore of reasons. So, you must post your code segment in order for people to help you. or, you simply put in debugging statements like display or simply beep at some suspicious location... you need scrutinize your code.

RobotC is a quite solid compiler. We have done many multi-tasking, synchronizing among tasks and sensors manipulation, some simple data array, bluetooth communication among robots, I2C, etc. All work fine.


Thu Feb 05, 2009 9:50 am
Profile WWW
Rookie

Joined: Sat Nov 22, 2008 7:14 pm
Posts: 12
Location: NJ
Post Re: Problems Running Automonous
I got it fixed, after a couple hours looking at my code, I found that the only void I was using was always false, using an anology its the equivilant of me trying to get the number 4 to be greater than 2 and less then -5 at the same time ;)

My bad

Thanks anyway

_________________
Ethan Spitz
Team 464 Programmer


Fri Feb 06, 2009 7:38 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 4 posts ] 

Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  



Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.