View unanswered posts | View active topics It is currently Wed Aug 05, 2020 10:33 am

Reply to topic  [ 1 post ] 
RobotC startup indefinite delay (networking) bug 
Author Message

Joined: Fri Apr 15, 2011 10:29 am
Posts: 37
Post RobotC startup indefinite delay (networking) bug
This one had me pulling my hair out last Sunday.

The school has an old Pentium 4 that is the students use for developing their FTC robots. It had RobotC 3.03 running on it, which was installed off a USB drive since it has no Internet access. I wasn't around when it was first installed, so I'm not sure how the license was activated, but a generous donor provided 30 licenses to the team so that every student could have a copy.

The students have built things up enough to start demonstrating it on the floor, which means either using Bluetooth or Samantha. Since we have 5 teams, it was felt that we should use the Samantha module.

Unfortunately, the latest USB drivers were not installed on the computer, so we installed the latest USB drivers that were distributed with the Samantha kit, and at the same time we updated to the latest version of RobotC (3.04).

After rebooting, we connected the computer to a wireless router and configured the network. After completing the setup, we proceeded to startup RobotC. At this point, RobotC hung. After 15 minutes of nothing, I killed it. After 90 minutes of trying everything we could think of (including re-installing, ununinstalling, re-installing, etc...), we gave up and decided to move to a new computer. The thought at this point was that something in 3.04 was too much for the lowly Pentium-4 box.

After un-connecting the wireless router and rebooting the box, on a whim I tried RobotC one more time. Low and behold, it worked fine and came up immediately. Success. So, we then re-connected the wireless router and configured the network so we could talk to the Samantha module, and everything worked peachy.

Unfortunately, at some point, we restarted RobotC, at which point it hung again. Given that things appeared to be related to the network configuration, we killed RobotC from the task manager, unconfigured the network, and then restarted RobotC which worked great.

At this point, I'm calling this a RobotC bug. I *suspect* what is happening is that RobotC is checking to see if a network connection exists, and if so, it's phoning home to check on the license. Regardless, this network connection only exists between this computer and a wireless router which connects to the Samantha module. There is no 'Internet' connection so that the computer can talk to the license server.

So, my request is to have the startup process have a reasonable timeout period where it assumes there isn't a valid Internet connection after some period of time (15 seconds seems a reasonable period of time) and treats the setup just like it does when there isn't any network connection at all, which in our case really is the reality of the situation.

Otherwise, we have to unconfigure/configure the network connection anytime we need to start RobotC on the computer if we want to use the Samantha module, which is a real pain!

But, in any case, it's nice to know a way to workaround the infinite hanging startup process. Hopefully this will help anyone else that may be experiencing this.


Thu Nov 03, 2011 9:55 pm
Display posts from previous:  Sort by  
Reply to topic   [ 1 post ] 

Who is online

Users browsing this forum: No registered users and 1 guest

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.