View unanswered posts | View active topics It is currently Thu Aug 13, 2020 2:11 pm

Reply to topic  [ 3 posts ] 
Samantha Wireless will not work 
Author Message

Joined: Sun Oct 07, 2012 2:37 pm
Posts: 2
Post Samantha Wireless will not work
I am out of ideas of what else to try to get RobotC to connect to the Samantha module and NXT block. What is really annoying is that the wireless connection seems to be setup correctly. I can access the NXT block via the IP website to get a status and I can ping the module through the command line. I can even see it through the link setup option in RobotC, a search shows the correct IP of the NXT block. But I can't do anything else; if I try to run the link test I get the following log error:

1417.611 create NXT Iterator FAILED (xFFFDD53F/-142017) 'Fantom Err: 'No More Items Found''
1417.613 create NXT Iterator FAILED (xFFFDD53F/-142017) 'Fantom Err: 'No More Items Found''
1417.617 Starting connection to Wireless brick (WIFI::NXT::
1417.837 Opened connection via WiFi to brick 'WIFI::NXT::' (NXT)

1417.855 sendDirectCommand: 'getBatteryLevel' :Response: Voltage: 8.3 Volts
1417.874 'Pinging' Robot Controller

1417.878 Send Message **<Get4ByteMemoryValue>** Read '0'; length 7; 15 04 00 00 00 00 00
1419.473 Reply message FAILED
1421.388 Closing communications link 'NXT-Real'

If I try to compile and download a program I get an error popup that says the block can not be found. I'm running RobotC 3.51, I've tried re-installing the USB drivers and the FTC suite and I get the same errors either way. I'm running the wireless network though an unsecured network on a linksys router and the system is 64 bit windows 7. I've also tried running this through an adhoc network and that doesn't work either. I don't know what else to try. I'm thinking the problem is related to the Fantom error but I can't find anything in the forums with a solution related to that. Any information or advice would be helpful.

Sun Oct 07, 2012 2:58 pm

Joined: Sun Oct 07, 2012 2:37 pm
Posts: 2
Post Re: Samantha Wireless will not work
Turns out the firmware on the samantha module wasn't getting updated like I thought it was. Make sure the version on the status page for the module reads 2.02 if everything else seems to be working. Not sure why firmware wasn't flashing the first time, but it finally works. The way to see if the firmware gets updated is if the wifi led stops flashing, which means everything got wiped correctly.

Sun Oct 07, 2012 4:02 pm
Site Admin
Site Admin

Joined: Thu May 24, 2012 12:15 pm
Posts: 722
Post Re: Samantha Wireless will not work
One more tip (for future reference); the Samatha Module can sometimes take a minute or two to flash the firmware. It pays to be patient with it, but if the process hasn't completed in 3 to 4 minutes you will probably have to restart the process. We do have a setup guide that walks you through this process (as well as some other nice ROBOTC/FTC guides) on our wiki:

Check out our Blog! And our Facebook page!
Need help? Take a look at our updated help documentation and the ROBOTC Forums.

Mon Oct 15, 2012 4:51 pm
Display posts from previous:  Sort by  
Reply to topic   [ 3 posts ] 

Who is online

Users browsing this forum: No registered users and 1 guest

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.