View unanswered posts | View active topics It is currently Wed Jul 08, 2020 7:58 am

Reply to topic  [ 2 posts ] 
external battery = 0.0 volts 
Author Message

Joined: Sat Oct 25, 2008 12:18 am
Posts: 19
Post external battery = 0.0 volts
We've been having an "external bat = 0.0" message recently on our bot, RobotC v 3.55... We were having it pretty regularly, like literally every few minutes. Tonight, we finally cleared out some memory, and it ran for 20 minutes, so we are hopeful that we just had too many programs, but if you look at the FTC forum below we are NOT alone. Anyone else having this problem and more importantly, anyone have a SOLUTION:o))

Chuck 0724, 4535 ... y-OFF-quot

We're encountering a rather unusual problem with our robot, and unfortunately we are still unsure if it's a programming issue. When we connect to the NXT and run tele-op, the robot either a) behaves erratically, randomly responding and not responding to joystick movement; b) is totally unresponsive, not moving at all; or c) is totally unresponsive, running infinitely in the direction of the last command after the occurrence of "a". When this happens the brick's screen informs us that the external battery is OFF. Occasionally, it tells us the external battery level is "0.0".

Sat Jan 19, 2013 2:05 am

Joined: Fri Aug 31, 2012 1:56 am
Posts: 8
Post Re: external battery = 0.0 volts
Make sure the NXT cables are plugged in and not internally broken. We forgot to plug our in the other day, and freaked out that our robot was connecting to the computer fine, and all lights were on, but not responding to commands whatsoever. We then realized our NXT port cables weren't plugged in and it worked fine after that.

Also make sure that those cables aren't being bent too severely and that they are not able to come out of the NXT with a little robot action. If this wire comes out in the the middle of a match, the robot will either immediately halt, or continue to move with the last command it was receiving.

Finally, if the USB cable going into the Samantha Module is loose, wiggling, or not staying connected, the symptoms that you have mentioned may happen. We were in a match in our last competition and the connection to the Samantha came loose. Our robot continued ramming into the wall per to out last command to move the robot forward. We told the refs we had lost control, but the FCS still said we were connected. To fix this problem, we zip-tied our USB cable sturdily in place connected to the Samantha module and it worked for the rest of competition.

I hope some of these fixes help!

natebot13, Brain Nugget

Mon Jan 21, 2013 4:30 pm
Display posts from previous:  Sort by  
Reply to topic   [ 2 posts ] 

Who is online

Users browsing this forum: No registered users and 2 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.