ROBOTC.net forums
http://robotc.net/forums/

Brake/Coast Not Working
http://robotc.net/forums/viewtopic.php?f=52&t=868
Page 1 of 1

Author:  TannerLD [ Thu Oct 30, 2008 6:48 pm ]
Post subject:  Brake/Coast Not Working

Hello,

We finally got our FTC kit so I get to play with all the bells and whistles of it for a few days.

Though, when I started to play with it, I noticed that I could not set the 12V DC Motors to coast or brake. The line of code below does nothing.
Code:
bFloatDuringInactiveMotorPWM = false;


Is this a bug or am I missing something?

Thanks
-Tanner

Author:  2008FTC3049 [ Sun Nov 30, 2008 11:29 pm ]
Post subject:  Re: Brake/Coast Not Working

Hey,

We've been having the exact same problem. Hopefully by bumping the thread there will be a reply.

Author:  commander599 [ Fri Dec 05, 2008 5:54 pm ]
Post subject:  Re: Brake/Coast Not Working

2008FTC3049 wrote:
Hey,

We've been having the exact same problem. Hopefully by bumping the thread there will be a reply.

:breakcomputer:

Author:  TannerLD [ Fri Dec 05, 2008 5:56 pm ]
Post subject:  Re: Brake/Coast Not Working

Glad to know its just not me and not a isolated problem.

-Tanner

Author:  commander599 [ Fri Dec 05, 2008 5:57 pm ]
Post subject:  Re: Brake/Coast Not Working

I know, It makes you feel stupid when it's just you and an isolated problem. Have you had any problems with a servo testbed?

Author:  Sunny1261 [ Sun Dec 07, 2008 1:09 pm ]
Post subject:  Re: Brake/Coast Not Working

We haven't gotten to test any Servos yet, but I have not heard of any problems. :?:

Author:  Ford Prefect [ Sun Dec 07, 2008 2:18 pm ]
Post subject:  Re: Brake/Coast Not Working

2008FTC3049 wrote:
Hopefully by bumping the thread there will be a reply.


abandon all hope!
all they'll do is threaten to ban you! :lol:

Author:  10nisman94 [ Mon Dec 08, 2008 5:36 pm ]
Post subject:  Re: Brake/Coast Not Working

Brake worked great for us, maybe its a bug.

At least this is a reply :bigthumb:

Author:  tfriez [ Tue Dec 09, 2008 10:45 am ]
Post subject:  Re: Brake/Coast Not Working

The Brake/Coast variable is meant for NXT motors, not for the FTC motors. The motor controller does not allow us to select "coast/brake" mode, so you'll have to kludge it.

Apply a speed of "1" to get the FTC motor to coast, and a speed of "0" to get the FTC motor to brake.

Page 1 of 1 All times are UTC - 5 hours [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/