Graphical Interface - Where did the function library go?
Page 1 of 1

Author:  triratht [ Tue Feb 10, 2015 7:10 pm ]
Post subject:  Graphical Interface - Where did the function library go?


The graphical interface does not working properly. I can see the function library along with the start page. However, it goes away when I start a new file. In fact, I tried opening a sample file from the correct file directory but the sample programs do not open as well. I tried clearing the registry keys but that didn't help when starting a new file.


Author:  JohnWatson [ Mon Feb 16, 2015 12:44 pm ]
Post subject:  Re: Graphical Interface - Where did the function library go?

This particular question has been answered via our ticketing system, but I will post the cause and resulting fix here for future reference. As a background, the computer had both a PLTW-provided ROBOTC building license file and a normal ROBOTC for VEX Robotics 4.X building license installed at the same time.

It looks like the licenses are in place and have activated properly; you may have encountered a rare issue where the PLTW-provided ROBOTC Building License file is preventing the full ROBOTC license from enabling the Graphical Natural Language programming option.

To resolve this issue, you will need to remove the PLTW-provided license file ("RCVEXPLTWV4.lfx") from the ROBOTC directory (typically C:/Program Files (x86)/Robomatter Inc/ROBOTC Development 4.x). Once this file has been removed or deleted, you will need to restart ROBOTC in order for the activation changes to take place. Once you confirm that the license is no longer showing up in the 'Help -> Manage Licenses' menu, close ROBOTC and reopen it using the ROBOTC for VEX Robotics Graphical 4.X icon.

This should allow you to use the Graphical Natural Language in ROBOTC. To confirm, removing the PLTW license will not cause your ROBOTC installation to lose any functionality (as the full ROBOTC & Robot Virtual Worlds licenses activate all of the functionality of the ROBOTC for VEX Robotics 4.x environment).

Author:  orozcol_rms [ Tue Apr 14, 2015 3:02 pm ]
Post subject:  Re: Graphical Interface - Where did the function library go?

What if you do not have the ability to deactivate the PLTW license?
Update: I found out how to do this. Thank you

Page 1 of 1 All times are UTC - 5 hours [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group