View unanswered posts | View active topics It is currently Tue Apr 28, 2015 2:20 pm

Reply to topic  [ 3 posts ] 
Natural Language TETRIX w/ undefined variable when compiling 
Author Message

Joined: Wed Aug 08, 2012 12:21 am
Posts: 1
Post Natural Language TETRIX w/ undefined variable when compiling
My team is attempting to use Platform Type = Natural Language TETRIX (version 3.08) with Compiler Target = Physical Robot for a simple program and hitting a compile error (**Error**:Undefined variable 'srvo_S1_C2_1'. 'short' assumed). NOTE: I am able to use the same #pragma statements when using the Platform Type = LEGO Mindstorms NXT + TEXTRIX with simple motor commands.

Here is the code:

#pragma config(Hubs, S1, HTMotor, HTServo, none, none)
#pragma config(Motor, mtr_S1_C1_1, motorD, tmotorNormal, openLoop, reversed)
#pragma config(Motor, mtr_S1_C1_2, motorE, tmotorNormal, openLoop)
#pragma config(Servo, srvo_S1_C2_1, servo1, tServoStandard)
#pragma config(Servo, srvo_S1_C2_2, servo2, tServoNone)
#pragma config(Servo, srvo_S1_C2_3, servo3, tServoNone)
#pragma config(Servo, srvo_S1_C2_4, servo4, tServoNone)
#pragma config(Servo, srvo_S1_C2_5, servo5, tServoNone)
#pragma config(Servo, srvo_S1_C2_6, servo6, tServoNone)
//*!!Code automatically generated by 'ROBOTC' configuration wizard !!*//

task main()
robotType(ranger); // Use the default REMBOT (change this if you use another robot type).

while(true) // Loop forever.
arcadeControl(); // Use Tank Control.

I would appreciate any thoughts on what we may be doing wrong.

Thank you!

UPDATE: I have tried closing, reopening, and recopying in the code, but I still get the same error. Thanks for looking into this for me!

Last edited by dan.thomas.dt on Wed Aug 08, 2012 11:32 pm, edited 1 time in total.

Wed Aug 08, 2012 12:37 am
Site Admin
Site Admin

Joined: Thu May 24, 2012 12:15 pm
Posts: 682
Post Re: Natural Language TETRIX w/ undefined variable when compi
I'll look into this for you, I'm getting the same error.

Update: This is an odd one, I re-opened ROBOTC and copied/pasted the code in again, and the error went away. We are still going to look into this though and find out why it's popping up in the first place.

We'll keep you updated and let you know what we find out/when we have a fix for it.

Check out our Blog! And our Facebook page!
Need help? Take a look at our updated help documentation and the ROBOTC Forums.

Wed Aug 08, 2012 12:52 pm
Site Admin
Site Admin

Joined: Wed Jan 24, 2007 10:42 am
Posts: 620
Post Re: Natural Language TETRIX w/ undefined variable when compi
This issue has been resolved in ROBOTC 3.50 and 3.51.


Timothy Friez
ROBOTC Developer - SW Engineer

Sat Sep 22, 2012 8:30 pm
Display posts from previous:  Sort by  
Reply to topic   [ 3 posts ] 

Who is online

Users browsing this forum: No registered users and 2 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.