View unanswered posts | View active topics It is currently Mon Jul 28, 2014 6:19 am






Reply to topic  [ 7 posts ] 
DWiFi sensor code does not connect 
Author Message
Novice

Joined: Sun Jun 13, 2010 9:26 am
Posts: 58
Post DWiFi sensor code does not connect
After getting the NXT2WiFi sensor to connect to my home WiFi access point I decided to try connecting the Dexter Industries WiFi sensor to also connect using WPA2. I made the following code changes in the dextind-wifi.h program file:

char *ssid = "pickles";

char *wpa_psk = "littlebob";

This is the output from the debug window:

Scanning for wifi sensor: 0 baud
echo_all_input_off
set_verbose
set wpa key
save config
set_verbose
closeAllCons
Beging parsing...
closeAllCons
Beging parsing...

Is there something else I need to do to get the sensor to connect to the home access point? I also tried to run the Dexter Industries sample codes but they would compile. I suspect that is because I am now running the new beta version of Robotc.

Mike


Sat Dec 08, 2012 3:22 pm
Profile
Moderator
Moderator
User avatar

Joined: Wed Mar 05, 2008 8:14 am
Posts: 3164
Location: Rotterdam, The Netherlands
Post Re: DWiFi sensor code does not connect
Which version of the suite are you using and which version of ROBOTC?

= Xander

_________________
| Professional Conduit of Reasonableness
| (Title bestowed upon on the 8th day of November, 2013)
| My Blog: I'd Rather Be Building Robots
| ROBOTC 3rd Party Driver Suite: [Project Page]


Sun Dec 09, 2012 3:33 am
Profile WWW
Novice

Joined: Sun Jun 13, 2010 9:26 am
Posts: 58
Post Re: DWiFi sensor code does not connect
I am using the new beta version of Robotc 3.55 and your new driver suite 3.2.

Mike


Sun Dec 09, 2012 11:40 am
Profile
Moderator
Moderator
User avatar

Joined: Wed Mar 05, 2008 8:14 am
Posts: 3164
Location: Rotterdam, The Netherlands
Post Re: DWiFi sensor code does not connect
Hey there,

I will try to have a look to see if I can recreate the issue here. Stay tuned.

= Xander

_________________
| Professional Conduit of Reasonableness
| (Title bestowed upon on the 8th day of November, 2013)
| My Blog: I'd Rather Be Building Robots
| ROBOTC 3rd Party Driver Suite: [Project Page]


Sun Dec 09, 2012 1:28 pm
Profile WWW
Moderator
Moderator
User avatar

Joined: Wed Mar 05, 2008 8:14 am
Posts: 3164
Location: Rotterdam, The Netherlands
Post Re: DWiFi sensor code does not connect
Just to let you know, I am very busy working on debugging the driver with my protocol analyser!

= Xander


Attachments:
2012-12-10 19.44.02.jpg
2012-12-10 19.44.02.jpg [ 3.3 MiB | Viewed 1664 times ]
2012-12-10_19-43-47.png
2012-12-10_19-43-47.png [ 49.49 KiB | Viewed 1664 times ]

_________________
| Professional Conduit of Reasonableness
| (Title bestowed upon on the 8th day of November, 2013)
| My Blog: I'd Rather Be Building Robots
| ROBOTC 3rd Party Driver Suite: [Project Page]
Mon Dec 10, 2012 2:46 pm
Profile WWW
Novice

Joined: Sun Jun 13, 2010 9:26 am
Posts: 58
Post Re: DWiFi sensor code does not connect
You have all the cool toys. This is why we are soooooooo thankful that you have created and maintain the 3rd party driver suite! The larger than life picture helps too!

No hurry, I will work on building and programming the NXTolaus robot to show off to my nephews this weekend while I wait.

Thank you for working on this for me.
Mike,


Mon Dec 10, 2012 6:46 pm
Profile
Moderator
Moderator
User avatar

Joined: Wed Mar 05, 2008 8:14 am
Posts: 3164
Location: Rotterdam, The Netherlands
Post Re: DWiFi sensor code does not connect
Progress so far:
The dWiFi connects to my WiFi network and gets an IP address, so that much is working. I need to find a nice way to handle the output from the sensor in a nice way.

Code:
Scanning for wifi sensor: 0 baud
echo_all_input_off
RS485read (5):
0

RS485write: AT&K1
set_verbose
RS485write: ATV0
RS485read (0):
set wpa key
RS485write: AT+WPAPSK=XXXXXXX,XXXXXX
RS485read (44):
Computing PSK from SSID and PassPhrase...

RS485read (0):
RS485write: AT+WA=Bazinga!
RS485read (0):
RS485write: AT+NDHCP=1
RS485read (0):
save config
RS485write: AT&W0
RS485write: AT&Y0
RS485read (0):
set_verbose
RS485write: ATV0
RS485read (0):
<snip snip>
RS485read (0):
RS485read (5):
0

RS485read (0):
RS485read (0):
RS485read (0):
RS485read (98):
    IP              SubNet         Gateway   
 192.168.178.26: 255.255.255.0: 192.168.178.1

_________________
| Professional Conduit of Reasonableness
| (Title bestowed upon on the 8th day of November, 2013)
| My Blog: I'd Rather Be Building Robots
| ROBOTC 3rd Party Driver Suite: [Project Page]


Tue Dec 11, 2012 3:40 pm
Profile WWW
Display posts from previous:  Sort by  
Reply to topic   [ 7 posts ] 

Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  



Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.