View unanswered posts | View active topics It is currently Mon Apr 21, 2014 8:15 am






Reply to topic  [ 9 posts ] 
slow startup in a fire-walled network 
Author Message
Expert

Joined: Sun Aug 19, 2007 2:43 pm
Posts: 134
Location: New Jersey
Post slow startup in a fire-walled network
RobotC starts up take a long time in our fire-wall infrastructure. Then, I tested it on an open network it is fine. Does anyone have the similar experience? Guess start up going out to the network for authentication?


Tue Jan 15, 2013 11:48 am
Profile WWW
Moderator
Moderator
User avatar

Joined: Wed Mar 05, 2008 8:14 am
Posts: 3108
Location: Rotterdam, The Netherlands
Post Re: slow startup in a fire-walled network
The slowness could also be caused by the check for the latest version. See if disabling it through this makes a difference:
Attachment:
2013-01-15_17-18-55.png
2013-01-15_17-18-55.png [ 22.8 KiB | Viewed 2093 times ]


= Xander

_________________
| Professional Conduit of Reasonableness
| (Title bestowed upon on the 8th day of November, 2013)
| My Blog: I'd Rather Be Building Robots
| ROBOTC 3rd Party Driver Suite: [Project Page]


Tue Jan 15, 2013 12:20 pm
Profile WWW
Expert

Joined: Sun Aug 19, 2007 2:43 pm
Posts: 134
Location: New Jersey
Post Re: slow startup in a fire-walled network
Thank you. I'll try that too tomorrow when I'm back in the lab.


Tue Jan 15, 2013 11:37 pm
Profile WWW
Site Admin
Site Admin

Joined: Wed Jan 24, 2007 10:42 am
Posts: 592
Post Re: slow startup in a fire-walled network
Do you happen to have a PROXY server that you're using? We are adding support to ROBOTC for the activation system to use proxy servers.

On bootup, ROBOTC checks to see if it has internet connectivity by checking to see if it can phone home to the activation server (we used to check if we could get to ROBOTC.net, but people would be incorrectly told they had full internet connectivity but couldn't activate because their school was blocking the activation server). This check is used to verify that we can load the live start page and other items. Is the latency from loading the live start page, or is it before you even get to that point?

_________________
Timothy Friez
ROBOTC Developer - SW Engineer
tfriez@robotc.net


Wed Jan 16, 2013 11:36 am
Profile
Expert

Joined: Sun Aug 19, 2007 2:43 pm
Posts: 134
Location: New Jersey
Post Re: slow startup in a fire-walled network
tfriez wrote:
...On bootup, ROBOTC checks to see if it has internet connectivity by checking to see if it can phone home to the activation server ... we can load the live start page and other items. Is the latency from loading the live start page, or is it before you even get to that point?


That's what I thought... yes, the latency seems to come from loading the live start page. I disabled both the "Load the splash startup page", and "Check for Newer Version of RobotC on Startup" did not. If it must do the online authentication, it needs to allow us to set it up to go through our proxy.


Wed Jan 16, 2013 3:02 pm
Profile WWW
Expert

Joined: Sun Aug 19, 2007 2:43 pm
Posts: 134
Location: New Jersey
Post Re: slow startup in a fire-walled network
I have just actually tested it by removing our proxy using the same computer, same router. RobotC started up very quickly. Therefore, since we are running this as educational institution where there are many kids are using. We have to set it up to go through proxy. I am guessing you are using port 80...?? Anyway, the more desirable setup is to allow site license owner to go thru an internal proxy server. Thank you in advance for this.


Wed Jan 16, 2013 3:31 pm
Profile WWW
Site Admin
Site Admin

Joined: Wed Jan 24, 2007 10:42 am
Posts: 592
Post Re: slow startup in a fire-walled network
Just to chime in here - We're working on a BETA release (mostly done) that will have PROXY support for the activation server functions. This should hopefully alleviate any slow response time for individuals using network wide proxy servers.

_________________
Timothy Friez
ROBOTC Developer - SW Engineer
tfriez@robotc.net


Mon Feb 11, 2013 4:58 pm
Profile
Expert

Joined: Sun Aug 19, 2007 2:43 pm
Posts: 134
Location: New Jersey
Post Re: slow startup in a fire-walled network
thank you...


Mon Feb 11, 2013 5:20 pm
Profile WWW
Site Admin
Site Admin

Joined: Wed Jan 24, 2007 10:42 am
Posts: 592
Post Re: slow startup in a fire-walled network
Hi Everyone,

If you're having this issue it's related to using a Proxy server when doing any type of "activation" requests. If you are experiencing this issue, please e-mail me at tfriez (at) robotc [dot] net if you would like to assist us in testing a build with proxy support. Otherwise, the next update of ROBOTC will include this functionality.

Thanks!

_________________
Timothy Friez
ROBOTC Developer - SW Engineer
tfriez@robotc.net


Mon Feb 18, 2013 9:54 am
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 9 posts ] 

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  



Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.